'81-'94 City owners group on Facebook.

Post whatever you like in here but try to keep it Honda City related!
User avatar
NewZulund
I'm New Here, Please Be Nice!
Posts: 7
Joined: Wed Aug 31, 2016 2:52 pm
Location: Wellington, New Zealand

'81-'94 City owners group on Facebook.

Postby NewZulund » Sun Nov 13, 2016 7:21 am

Hello City-goers.

I've created a facebook group along with ANTHRAXXX encompassing all first and second gen Honda Citys. Hopefully this will provide a good spot for selling turbo & non-turbo parts and discussing content relevant to other city models.

The group is in its infancy (started 12/11/16) so chuck your City owning mates in there too if you'd like. The more the merrier :mrgreen:.

https://www.facebook.com/groups/HondaCityOwnersClub/

Image

User avatar
NewZulund
I'm New Here, Please Be Nice!
Posts: 7
Joined: Wed Aug 31, 2016 2:52 pm
Location: Wellington, New Zealand

Re: '81-'94 City owners group on Facebook.

Postby NewZulund » Sun Nov 13, 2016 7:23 am

Also if you have a nice photo of a city you'd like us to put as the group photo send it through.

User avatar
Sander
Forum Participant
Posts: 18
Joined: Sun Nov 06, 2016 9:59 pm
Location: Perth,WA

Re: '81-'94 City owners group on Facebook.

Postby Sander » Sun Nov 13, 2016 4:53 pm

Churrrr sounds good,will upload some tomorrow! cracked my windscreen today when I hosed it off :(

ANTHRAXXX
Forum Addict
Posts: 659
Joined: Wed Mar 11, 2009 11:04 am
Location: Perth WA

Re: '81-'94 City owners group on Facebook.

Postby ANTHRAXXX » Mon Nov 14, 2016 10:50 am

Sander I have a spare windscreen sitting in my shed removed from a T2...had it for about 3 yrs now so if you need one ;)

User avatar
rafke
Forum Enthusiast
Posts: 189
Joined: Mon Nov 03, 2014 11:13 pm
Location: Belgium

Re: '81-'94 City owners group on Facebook.

Postby rafke » Mon Nov 14, 2016 7:19 pm

Well done NewZulund. Good idea :)

User avatar
Sander
Forum Participant
Posts: 18
Joined: Sun Nov 06, 2016 9:59 pm
Location: Perth,WA

Re: '81-'94 City owners group on Facebook.

Postby Sander » Mon Nov 14, 2016 11:10 pm

ANTHRAXXX wrote:Sander I have a spare windscreen sitting in my shed removed from a T2...had it for about 3 yrs now so if you need one ;)

Awesome! :D will keep that in mind for sure,I'm on to a lead....there's a city sitting in Welshpool apparently...no motor or box but might have a screen. going investigating tomorrow or Wednesday. You haven't got a working speedo have ya?
I'll need to do rust repair when the current windscreen is out.

ANTHRAXXX
Forum Addict
Posts: 659
Joined: Wed Mar 11, 2009 11:04 am
Location: Perth WA

Re: '81-'94 City owners group on Facebook.

Postby ANTHRAXXX » Tue Nov 15, 2016 9:15 am

I have 2 complete dash clusters, one is from a T2 the other a stock city i think.

User avatar
Sander
Forum Participant
Posts: 18
Joined: Sun Nov 06, 2016 9:59 pm
Location: Perth,WA

Re: '81-'94 City owners group on Facebook.

Postby Sander » Tue Nov 15, 2016 12:05 pm

I've got 2 T2 ones,I got the mechanism going but still no reading on the lcd display. swapped electronics,nothing...resoldered some sus soldering points...still nothing. 2 duds lol Shame because the odometer and "boost gauge lol" work fine.


Return to “General”

Who is online

Users browsing this forum: Bing [Bot] and 12 guests